Bug with jquery 1.7

Nov 23, 2011 at 3:58 PM

If I use the example.htm provided in the download and I change jquery/1.6.2 by jquery/1.7, a bug appears :

in this example :

<div class="rateit" id="rateit5" data-rateit-min="2">
</div>
<div>
    <span id="value5"></span>
    <span id="hover5"></span>
</div>
 
<script type="text/javascript">
    $("#rateit5").bind('rated', function (event, value) { $('#value5').text('You\'ve rated it: ' + value); });
    $("#rateit5").bind('reset', function () { $('#value5').text('Rating reset'); });
    $("#rateit5").bind('hover', function (event, value) { $('#hover5').text('Hovering over: ' + value); });
</script>           
The value of the rate is not displayed anymore in #hover5, only 'undefined' ( nevertheless, other features seems to work : stars are displayed etc...)
This bug appears with jquery 1.7 and 1.7.1 not with 1.6.x : how to solve the problem while using jquery 1.7.x ?
Coordinator
Nov 24, 2011 at 4:28 AM
Thanks for the report. I will have a look at it later today.

Gidon

On 23 בנוב 2011, at 18:58, "ericdupo" <notifications@codeplex.com> wrote:

From: ericdupo

If I use the example.htm provided in the download and I change jquery/1.6.2 by jquery/1.7, a bug appears :

in this example :

<div class="rateit" id="rateit5" data-rateit-min="2">
</div>
<div>
<span id="value5"></span>
<span id="hover5"></span>
</div>
<script type="text/javascript">
$("#rateit5").bind('rated', function (event, value) { $('#value5').text('You\'ve rated it: ' + value); });
$("#rateit5").bind('reset', function () { $('#value5').text('Rating reset'); });
$("#rateit5").bind('hover', function (event, value) { $('#hover5').text('Hovering over: ' + value); });
</script>
The value of the rate is not displayed anymore in #hover5, only 'undefined' ( nevertheless, other features seems to work : stars are displayed etc...)
This bug appears with jquery 1.7 and 1.7.1 not with 1.6.x : how to solve the problem while using jquery 1.7.x ?
Feb 24, 2012 at 1:43 AM

Hi Gidon,

   do u have fix this bug?

Coordinator
Feb 24, 2012 at 10:03 AM

Please have a look at the issue tracker: http://rateit.codeplex.com/workitem/417

This is a jQuery bug, and should be fixed with version 1.7.2